Opened 3 years ago

Closed 3 years ago

#11608 closed Bug/Something is broken (fixed)

Can't Login

Reported by: https://id.mayfirst.org/grannan Owned by: https://id.mayfirst.org/jaimev
Priority: Urgent Component: Tech
Keywords: roundcube Cc: https://id.mayfirst.org/jamie, https://id.mayfirst.org/srevilak, douglas@…
Sensitive: no

Description

Hi, I am unable to login to my account. I have double checked the user name and password. Is there something I can do?

Thanks,

Doug

Change History (21)

comment:1 Changed 3 years ago by https://id.mayfirst.org/jaimev

  • Owner set to https://id.mayfirst.org/jaimev
  • Status changed from new to assigned

This was probably due to didier being offline during its migration to a new host server last night. Can you try your login again?

comment:2 Changed 3 years ago by https://id.mayfirst.org/grannan

I have tried to login several times, so far no luck. I just tried again with no luck.

Is there anyway to reset this or something? I'm not going to lie, I am not a tech wizard so I am a little stuck.

Thanks for your reply, please help me.

Doug

comment:3 Changed 3 years ago by https://id.mayfirst.org/jaimev

What service are you attempting to login to Doug?

comment:4 Changed 3 years ago by https://id.mayfirst.org/grannan

My email, it's grannan@….

comment:5 Changed 3 years ago by https://id.mayfirst.org/jaimev

Can you try logging in vía our webmail service https://roundcube.mayfirst.org?

comment:6 Changed 3 years ago by https://id.mayfirst.org/grannan

This is the message I received when I logged in

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator at apache@… to inform them of the time this error occurred, and the actions you performed just before this error.

More information about this error may be available in the server error log.

comment:7 Changed 3 years ago by https://id.mayfirst.org/jaimev

I see the error you are referring to now. I am looking into it. I apologize for the inconvenience.

comment:8 Changed 3 years ago by https://id.mayfirst.org/jaimev

  • Cc https://id.mayfirst.org/jamie https://id.mayfirst.org/srevilak added
  • Keywords roundcube added
  • Priority changed from Medium to Urgent

cc'ing jamie and srevilak here for more input. I see the following errors in roundcube logs.

[01-Apr-2016 14:21:58 -0400]: <6jpqsr06> IMAP Error: Login failed for grannan from 73.188.0.230. AUTHENTICATE PLAIN: Account is temporarily unavailable. in /srv/roundcube/program/lib/Roundcube/rcube_imap.php on line 197 (POST /?_task=login?_task=login&_action=login)

Last edited 3 years ago by https://id.mayfirst.org/jaimev (previous) (diff)

comment:9 Changed 3 years ago by https://id.mayfirst.org/grannan

OK thanks, if you need to email me please use douglas@…

comment:10 Changed 3 years ago by https://id.mayfirst.org/srevilak

  • Cc douglas@… added

comment:11 Changed 3 years ago by https://id.mayfirst.org/srevilak

Offhand, I don't know have a good explanation for why login attempts would consistenly fail. Nor do I have an explanation for the internal server error from roundcube.

I will do some digging.

Steve

comment:12 Changed 3 years ago by https://id.mayfirst.org/grannan

Thanks so much Steve, emails are getting returned. I really appreciate your help

Thanks

Doug

comment:13 Changed 3 years ago by https://id.mayfirst.org/srevilak

I noticed this in didier's mail.info

Mar 31 22:21:46 didier dovecot: lmtp(21187, grannan): Error:
MykCHTrb/VbDUgAAkEOI5Q: sieve: binary save: failed to create temporary
file: open(/usr/local/share/dovecot/global.svbin.didier.21187.)
failed: Permission denied

I ran sievec global.sieve to recompile the svbin file. But that shouldn't affect login attempts.

Here's something that doesn't look right.

  • The dovecot.proxy table on gil says that grannan's mail host is secure.critpath.org.
  • Gil thinks that secure.critpath.org resolves as 209.234.249.196
  • 209.234.249.196 is not an IP address on didier.

Instead, didier has

1 didier:/etc/network/interfaces.d# cat /etc/network/interfaces
# handled by puppet
source-directory /etc/network/interfaces.d

0 didier:/etc/network/interfaces.d# cat /etc/network/interfaces.d/eth0 
auto eth0
iface eth0 inet static
  address 162.247.75.107
  netmask 255.255.255.0
  gateway 162.247.75.1

didier.pp has this interface commented out.

  class { "mayfirst::m_interface": }
  #mayfirst::m_interface::set { "209.234.253.102/27": gateway => "209.234.253.97" }
  mayfirst::m_interface::set { "162.247.75.107/24": gateway => "162.247.75.1" }
  #mayfirst::m_interface::set { "209.234.249.196/27": label => "secure" }

I see what the problem is. Dovecot proxy wants to send grannans mail retrieval to secure.critpath.org, but secure.critpath.org's IP address is no longer configured on didier.

git tells me that this interface was commented out (of didier.pp) on 3/31/2016, in revision e6885ee6.

Jamie -- can you provide any insight here? (Perhaps this is related to the colo move?)

comment:14 Changed 3 years ago by https://id.mayfirst.org/options

I am having the same problem since about 9 pm EDT March 31, till now, 10 pm April 1st. I get "Account is temporarily unavailable." trying to login via POP, and "Remote server is temporarily unavailable." when trying to login to horde webmail. Roundcube login results in an Apache internal server error. My email address is from critpath.org as well. - charles

Last edited 3 years ago by https://id.mayfirst.org/options (previous) (diff)

comment:15 Changed 3 years ago by https://id.mayfirst.org/grannan

Hello, is there any chance of this being resolved over the weekend?

comment:16 Changed 3 years ago by https://id.mayfirst.org/jamie

Thank you for the sleuthing steve. You are right - Philadelphia Fight did not update their DNS as requested in our various service advsirories (https://status.mayfirst.org/2016/28/).

Currently we have an exception to our pop map rule - critpath users are allowed to connect via the domain secure.critpath.org rather than didier.mayfirst.org to preserve backward compatibility.

However, secure.critpath.org's IP was not updated. So I have removed this exception and now all critpath users will be directed to didier.mayfirst.org instead.

THis means if you use our webmail (https://roundcube.mayfirst.org/) or if your email client is configured to use mail.mayfirst.org - then everything should now work (and this should cover you, grannan).

However, it means that people who have their email programs still configured to use secure.critpath.org than it will fail.

grannan - can you try again? It should be working now.

jamie

I've also sent an email to fight asking them to update their DNS records

comment:17 Changed 3 years ago by https://id.mayfirst.org/grannan

Jamie, thank you so much I'm not getting the same error login message. I got a few emails from Thursday night, but nothing from yesterday or this morning. I sent two test emails from another email address over the last 30 minutes and they didn't come thru to my critpath email. So I guess I'm not sure if I'm still going to receive emails. Should I change my settings?

Thanks

Doug

comment:18 Changed 3 years ago by https://id.mayfirst.org/jamie

Thanks for your patience with this Doug. I see the new problem. The domain critpath.org (which is currently controlled by fight.org) is configured to send email to mail.critpath.org, and that domain has the old didier IP address.

So, no email sent to you has been delivered, since that IP address no longer exists.

This is the bad news.

There are two pieces of good news:

  • Mail delivery to non-existing servers typically are retried for up to 4 days before they get lost. So, we have until monday to get this resolved before any email is lost.
  • Fight has already responded to say they are working on it.

As soon as they update the DNS records, the email should start to slowly (and irregularly) be delivered.

There will be a period of about 15 minutes while our systems are synchronized that might result in a few messages bouncing. However, I expect that nearly all messages should be delivered.

I will follow up again with fight to get an estimate on when the change will be made.

jamie

comment:19 Changed 3 years ago by https://id.mayfirst.org/grannan

Jamie you are the most stable relationship in my life. Thanks so much.

comment:20 Changed 3 years ago by https://id.mayfirst.org/jamie

  • Resolution set to fixed
  • Status changed from assigned to feedback

Done! Thanks to Fight's very fast response, everything seems to be flowing now. It might take a few hours for all the email to come through. Please re-open if you have any other trouble.

comment:21 Changed 3 years ago by https://id.mayfirst.org/grannan

  • Status changed from feedback to closed

Great, I'm getting my emails, thanks so much.

Doug

Please login to add comments to this ticket.

Note: See TracTickets for help on using tickets.