Opened 3 years ago

Closed 3 years ago

#11575 closed Bug/Something is broken (fixed)

howard:/var full

Reported by: Steve Revilak Owned by: Steve Revilak
Priority: Medium Component: Tech
Keywords: gnusocial howard.mayfirst.org Cc:
Sensitive: no

Description

I had a problem logging in to social.mayfirst.org this evening, and logged into howard to examine.

One possible problem

0 howard:/var/log# df -h . 
Filesystem                  Size  Used Avail Use% Mounted on
/dev/mapper/vg_howard0-var  4.6G  4.4G     0 100% /var

Most of the space was being taken up by

0 howard:/var/log# ls -ltr statusnet.log statusnet.log.1
-rw-r--r-- 1 www-data www-data 865373331 Mar 20 06:30 statusnet.log.1
-rw-r--r-- 1 www-data www-data 977338368 Mar 20 20:58 statusnet.log

So I did

0 howard:/var/log# truncate -s0 statusnet.log.1 statusnet.log

which gives

0 howard:/var/log# df -h . 
Filesystem                  Size  Used Avail Use% Mounted on
/dev/mapper/vg_howard0-var  4.6G  2.7G  1.8G  61% /var

I'll see if I can tone down statusnet's logging verbosity.

Change History (5)

comment:1 Changed 3 years ago by Steve Revilak

Owner: set to Steve Revilak
Status: newassigned

comment:2 Changed 3 years ago by Steve Revilak

Also large sources of data

0 howard:/var/log/nginx# ls -l friends.mayf*
-rw-r--r-- 1 friends root 1326999406 Mar 13 09:14 friends.mayfirst.org.access_log
-rw-r--r-- 1 friends root   51858765 Mar 13 09:14 friends.mayfrist.org.error_log

130 howard:/var/log/nginx# head -1 friends.mayfirst.org.access_log
24.126.47.67 - - [25/May/2013:06:13:33 -0400] "GET /ping?f=&uid=3&_=1369476798735 HTTP/1.1" 200 1638 "https://friends.mayfirst.org/profile/nat" "Mozilla/5.0 (X11; Linux x86_64; rv:20.0) Gecko/20100101 Firefox/20.0 Iceweasel/20.0"

Removed these files as well. Apparently they weren't being rotated.

Looks better afterwards

0 howard:/var/log/nginx# df -h . 
Filesystem                  Size  Used Avail Use% Mounted on
/dev/mapper/vg_howard0-var  4.6G  1.4G  3.1G  31% /var

comment:3 Changed 3 years ago by Steve Revilak

Found some setup suggestions on Sazius's web site: https://sjoberg.fi/blog/statusnet.html

We'll see if this bit in config.php helps

addPlugin('LogFilter', array(
   'priority' => array(LOG_DEBUG => false, LOG_INFO => false)
));

Restarted daemons as

cd gnusocial/social.mayfirst.org/web/scripts
su --shell=/bin/bash -c ./stopdaemons.sh www-data
su --shell=/bin/bash -c ./startdaemons.sh www-data

comment:4 Changed 3 years ago by Steve Revilak

Resolution: fixed
Status: assignedfeedback

That seemed to fix the login problem at least.

comment:5 Changed 3 years ago by automatic

Status: feedbackclosed

No news is good news (we hope)! Given the lack of feedback, we think this ticket can be closed.

Please login to add comments to this ticket.

Note: See TracTickets for help on using tickets.