Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#11282 closed Task/To do item (fixed)

Is it possible to install alpine on floriberto?

Reported by: https://id.mayfirst.org/gripuqam Owned by: https://id.mayfirst.org/srevilak
Priority: Low Component: Tech
Keywords: Cc:
Sensitive: no

Description

alpine is a text-based email client, (friendly for novices but powerful) but it is true :-)

I am trying mutt, but I never understood how to make it work, I used UW pine for years so alpine is better for me.

I would really love if it could be installed on floriberto (and maybe sisters and brothers like ossie and chelsea).

Change History (4)

comment:1 Changed 3 years ago by https://id.mayfirst.org/srevilak

  • Owner set to https://id.mayfirst.org/srevilak
  • Status changed from new to assigned

Debian has an alpine package.

0 floriberto:~# apt-cache show alpine
Package: alpine
Version: 2.11+dfsg1-3
Installed-Size: 7038
Maintainer: Asheesh Laroia <asheesh@asheesh.org>
Architecture: amd64
Replaces: pine
Depends: mlock, libc6 (>= 2.15), libgssapi-krb5-2 (>= 1.10+dfsg~), libkrb5-3 (>= 1.6.dfsg.2), libldap-2.4-2 (>= 2.4.7), libpam0g (>= 0.99.7.1), libssl1.0.0 (>= 1.0.0), libtinfo5
Recommends: alpine-doc
Suggests: aspell, mail-transport-agent | exim4
Conflicts: pine
Description-en: Text-based email client, friendly for novices but powerful
 Alpine is an upgrade of the well-known PINE email client.  Its name derives
 from the use of the Apache License and its ties to PINE.
 .
 It features a full suite of support for mail protocols like IMAP and SMTP and
 security protocols like TLS.  It uses curses for its interface.
Description-md5: 3ddd074b130edc15ad4419408e6d3266
Homepage: http://patches.freeiz.com/alpine/
Tag: implemented-in::c, interface::text-mode, mail::user-agent,
 network::client, protocol::imap, protocol::pop3, protocol::smtp,
 protocol::ssl, role::program, uitoolkit::ncurses, works-with::mail
Section: mail
Priority: optional
Filename: pool/main/a/alpine/alpine_2.11+dfsg1-3_amd64.deb
Size: 1738530
MD5sum: c22e0fb30892821665810c53fe552606
SHA1: 779fa91e013823feb39b3f9830771d428ea0488c
SHA256: 4abd2676ef3e37bcd998b93262011e4faad8f62860eccd674176308010d0db00

Any objections to installing alpine, alpine-doc, alpine-pico, and pilot on the three machines mentioned in the description?

comment:2 Changed 3 years ago by https://id.mayfirst.org/jamie

That's fine with me - in fact, I would suggest adding it to the MOSH puppet file so it goes to all MOSHes for consistency sake.

comment:3 Changed 3 years ago by https://id.mayfirst.org/srevilak

  • Resolution set to fixed
  • Status changed from assigned to closed

Installed alpine, alpine-doc on floriberto, ossie, chelsea.

Added alpine, alpine-doc to $mosh_packages (in m_mosh.pp). commit 05d317db5a4ebbe94872e0a4bb8fc97892f1f3a5

comment:4 Changed 3 years ago by https://id.mayfirst.org/gripuqam

It works well on floriberto, thanks!

Please login to add comments to this ticket.

Note: See TracTickets for help on using tickets.