Opened 10 years ago

Closed 10 years ago

#1082 closed Bug/Something is broken (fixed)

Red/Control Panel does not properly set shell when creating new email accounts

Reported by: https://id.mayfirst.org/jamie Owned by: https://id.mayfirst.org/jamie
Priority: Medium Component: Tech
Keywords: red email Cc:
Sensitive: no

Description

In some instances (see #1081) it appears as though Red (the control panel software) is not properly changing a user's shell from /bin/false to /bin/bash when an email address is being created.

Change History (3)

comment:1 Changed 10 years ago by https://id.mayfirst.org/jamie

  • Keywords red email added

comment:2 Changed 10 years ago by https://id.mayfirst.org/jamie

#1209 also suffered from this bug.

comment:3 Changed 10 years ago by https://id.mayfirst.org/jamie

  • Resolution set to fixed
  • Status changed from new to closed

This problem should now be fixed. The problem is that the default path for the usermod command was set to /bin/true (which is useful for testing purposes when running as non-root user) rather than /usr/sbin/usermod which is the required setting if we want shells to be properly set by red.

The problem was fixed in red itself however it wasn't changed in the admin scripts which install red until now.

Please login to add comments to this ticket.

Note: See TracTickets for help on using tickets.