Opened 4 years ago

Last modified 4 years ago

#10674 assigned Bug/Something is broken

need help with Horde - emails not being drawn from address book

Reported by: https://id.mayfirst.org/portside-submission Owned by: https://id.mayfirst.org/jamie
Priority: Medium Component: Tech
Keywords: horde, expanding addresses Cc: jamie@…, ross@…, bxcohen@…, jschaffner@…, jschaffner14@…
Sensitive: no

Description

For past two weeks, the auto fill for emails in our Horde address book has not been working.

Just went through trying to change setting options for the address book.

After selecting which fields to draw from, the pop=up says settings saved, but you can see that the changes "did not take" - they did not remain when going to SAVE.

Can someone look at this?

Thanks.

Jay

Attachments (1)

horde-auto-complete.png (19.0 KB) - added by https://id.mayfirst.org/jamie 4 years ago.

Download all attachments as: .zip

Change History (20)

comment:1 Changed 4 years ago by https://id.mayfirst.org/jaimev

Hi Jay,

I will attempt to reproduce the error you describe.

Jaime

comment:2 Changed 4 years ago by https://id.mayfirst.org/jaimev

  • Keywords horde expanding addresses added
  • Owner set to https://id.mayfirst.org/jamie
  • Status changed from new to assigned

Yes, I was able to reproduce the same behavior. I am not sure that the error resides in the preferences interface but yes I do see that when I view the interface under Preferences->Mail menu and then under the Compose column link to Address Books , I can choose one of my "Selected address books", and then below the name of fields to search when expanding addresses. Saving my changes does return everything to an unselected state but if I click on any of my selected address books again i see it does remember which fields I selected previously.

In any case email address expansion does not work for me when composing a new message. I have searched http://wiki.horde.org/ and looked for outstanding bugs related to address expansion in https://bugs.horde.org/search.php and I haven't turned up anything useful. Let's loop jamie into this thread to help suggest other means of debugging.

comment:3 Changed 4 years ago by https://id.mayfirst.org/jamie

Thanks Jay for reporting the problem.

I found this thread - that describes the symptom:

http://comments.gmane.org/gmane.comp.horde.user/36456

The conclusion is that the problem is with ckeditor. I'm still tracking that down...

comment:4 Changed 4 years ago by https://id.mayfirst.org/jamie

  • Resolution set to fixed
  • Status changed from assigned to closed

Hi Jay - can you try it again? I think it is working.

The link in my comment above does seem to show what the problem is. And it does seem to be the problem. And it does seem to be a bug in ckeditor.

I'm pretty sure the problem started when I upgraded our webmail services (see 9951#comment:24).

I fixed it by adding the following to our apache configuration:

Alias /imp/core/ /usr/share/javascript/ckeditor/core/

The root cause is that ckeditor it not emitting the proper URL when including files.

comment:5 Changed 4 years ago by https://id.mayfirst.org/portside-submission

  • Resolution fixed deleted
  • Status changed from closed to assigned

tried numerous times today - not working. Fix did not hold - this may be related to server switch.

comment:6 Changed 4 years ago by https://id.mayfirst.org/jamie

Confirmed - not working for me either. Working on it...

comment:7 Changed 4 years ago by https://id.mayfirst.org/jamie

On second thought... it does seem to be working. I thought it wasn't working because I only typed one letter... but it requires you type at least three characters. Does that work for you?

comment:8 Changed 4 years ago by https://id.mayfirst.org/portside-submission

still not working.

just tried typing "jscha" and "jay s"

Both in addressbook, neither self-populated.

comment:9 Changed 4 years ago by https://id.mayfirst.org/jamie

Hi Jay,

What user account are you logged into when you get this error? Also, what browser are you using?

jamie

comment:10 Changed 4 years ago by https://id.mayfirst.org/portside-submission

using Firefox - it worked previously with this browser.

portside-submission

comment:11 Changed 4 years ago by https://id.mayfirst.org/jamie

I wonder if it had anything to do with the login problems with #10717? Can you let me know if this issue is continuing?

comment:12 Changed 4 years ago by https://id.mayfirst.org/portside-submission

In Horde, did not pull name from Addressbook. just re-added myself. still nada. There is only one addressbook, and it is checked as default.

Bigger problem is inassessiblity.

comment:13 Changed 4 years ago by https://id.mayfirst.org/portside-submission

is addressbook now on mumia?

comment:14 Changed 4 years ago by https://id.mayfirst.org/jamie

No - regardless of which server you are on, horde keeps all address book entries in horde itself. It is linked to your username. So, the same address book should still be available.

Can I change your password briefly to test? I can then change it back to what it was originally.

comment:15 Changed 4 years ago by https://id.mayfirst.org/portside-submission

go ahead, but change back quick, since Barry is also working with queue.

comment:16 Changed 4 years ago by https://id.mayfirst.org/jamie

I've logged in, tested, loggd out and changed the password back.

I was able to see the auto-complete working. I will upload a screen grab...

Changed 4 years ago by https://id.mayfirst.org/jamie

comment:17 Changed 4 years ago by https://id.mayfirst.org/jamie

comment:18 Changed 4 years ago by https://id.mayfirst.org/jamie

Jay - I'm not sure why this isn't working on your computer. Can you try clearing the cache? (https://support.mozilla.org/en-US/kb/how-clear-firefox-cache)

comment:19 Changed 4 years ago by https://id.mayfirst.org/jaimev

Has this problem been resolved for you?

Jaime

Please login to add comments to this ticket.

Note: See TracTickets for help on using tickets.