Opened 11 years ago

Closed 11 years ago

#1027 closed Bug/Something is broken (fixed)

Question about Email Address in Admin Settings for Drupal 4.7

Reported by: James Carlson Owned by: Jamie McClelland
Priority: Medium Component: Tech
Keywords: Cc:
Sensitive: no

Description

Hi Mayfirst

I have a curious problem. Our email address at LSNTAP.Org for registration, passwords, etc is info@…. Info@… is a group email list hosted by Google Apps. When I send emails to it, it works fine and reaches various people on our staff. This is the case for both emails originating inside Google Apps, and outside. Unfortunately, when LSNTAP.Org sends email out to that address, something unusual happens. Instead of sending email to james@…, it sends it to my old email account, jamesbcarlson@…. Also, it seems to be using a different, older list of names, then what Google Apps has selected. Does anyone know what might the problem be? Are there settings elsewhere on the site I should be aware of? Thanks and any help is much appreciated.

James

Change History (2)

comment:1 in reply to:  description ; Changed 11 years ago by Jamie McClelland

Hi James,

First I'll try to re-state what I think the problem is:

When you send an email to info@lsntap.org from any where on the Internet, it gets delivered one way.

However, when your web site (http://lsntap.org/) sends email to info@lsntap.org, some different happens.

I see that you are not using May First/People Link to handle your email, but instead, your mx records point directly to google:

0 jamie@liberace:scripts$ dig +short -t mx lsntap.org
30 ASPMX3.GOOGLEMAIL.COM.
20 ALT2.ASPMX.L.GOOGLE.COM.
10 ASPMX.L.GOOGLE.COM.
30 ASPMX4.GOOGLEMAIL.COM.
30 ASPMX2.GOOGLEMAIL.COM.
20 ALT1.ASPMX.L.GOOGLE.COM.
30 ASPMX5.GOOGLEMAIL.COM.
0 jamie@liberace:scripts$

I would encourage you not to trust something as critical as your email to a profit driven corporation!

However, if you do want to deliver your email via google, you should delete the email settings in your Members Control panel. Because you have configured email addresses in the members control panel, the server that hosts lsntap.org thinks email for your domain should be handled locally - so it follows the rules set up in our members control panel (which is configured with the older list of email addresses).

This is a bug with the MFPL server - it should be smart enough to know that email for lsntap.org should be delivered to google, not locally. However, until we fix the bug, you'll need to delete all the email address accounts in the MFPL members control panel, at which point the server will no longer try to deliver your email locally, but instead will forward it to google.

comment:2 in reply to:  1 Changed 11 years ago by James Carlson

Resolution: fixed
Status: newclosed

Excellent! That's just what I wanted to know. Especially thanks for the quick reply.

James

Replying to https://id.mayfirst.org/jamie:

Hi James,

First I'll try to re-state what I think the problem is:

When you send an email to info@lsntap.org from any where on the Internet, it gets delivered one way.

However, when your web site (http://lsntap.org/) sends email to info@lsntap.org, some different happens.

I see that you are not using May First/People Link to handle your email, but instead, your mx records point directly to google:

0 jamie@liberace:scripts$ dig +short -t mx lsntap.org
30 ASPMX3.GOOGLEMAIL.COM.
20 ALT2.ASPMX.L.GOOGLE.COM.
10 ASPMX.L.GOOGLE.COM.
30 ASPMX4.GOOGLEMAIL.COM.
30 ASPMX2.GOOGLEMAIL.COM.
20 ALT1.ASPMX.L.GOOGLE.COM.
30 ASPMX5.GOOGLEMAIL.COM.
0 jamie@liberace:scripts$

I would encourage you not to trust something as critical as your email to a profit driven corporation!

However, if you do want to deliver your email via google, you should delete the email settings in your Members Control panel. Because you have configured email addresses in the members control panel, the server that hosts lsntap.org thinks email for your domain should be handled locally - so it follows the rules set up in our members control panel (which is configured with the older list of email addresses).

This is a bug with the MFPL server - it should be smart enough to know that email for lsntap.org should be delivered to google, not locally. However, until we fix the bug, you'll need to delete all the email address accounts in the MFPL members control panel, at which point the server will no longer try to deliver your email locally, but instead will forward it to google.

Please login to add comments to this ticket.

Note: See TracTickets for help on using tickets.