Opened 4 years ago

Last modified 4 years ago

#10073 assigned Bug/Something is broken

Need site restored

Reported by: https://id.mayfirst.org/lizmestres Owned by: https://id.mayfirst.org/ross
Priority: High Component: Tech
Keywords: sync-sites drupal7 Cc:
Sensitive: no

Description

Hi, I've been trying to work on the Commons site using the test site that I worked with in May. I've been reading whatever I can about how to bring the up-to-date databases from the live site into the staging site. I've been trying to use the back-up and migrate module an/or phpmyadmin export and import but it keeps messing up. Can you restore the test site--new.thecommonsbrooklyn.org to the state it was in yesterday? And do you have any tips on how to move the data to the test site? Thanks, Liz

Change History (3)

comment:1 Changed 4 years ago by https://id.mayfirst.org/ross

  • Keywords sync-sites drupal7 added
  • Owner set to https://id.mayfirst.org/ross
  • Status changed from new to assigned

Hi Liz,

First, always...always backup your databases before you import another database. I have restored a backup database, but I can't tell what it's supposed to look like or if the restore is what you needed.

As far as syncing sites goes. The easiest way is from the command line using rsync and mysqldump (or drush sql-dump). I'd be happy to do this for you if you want, just make sure to give me the correct current domain to sync from.

~/ross

comment:2 Changed 4 years ago by https://id.mayfirst.org/lizmestres

Hi Ross, Thank you so much! It would be WONDERFUL if you could sync the test site (new.thecommonsbrooklyn.org) so that it matches the live site (thecommonsbrooklyn.org).

I've been trying to learn how to do that myself and spent the day trying to make aliases for a local site, test site, and live site so that I could learn to use drush for keeping the sites synced, updated, etc. I was using these directions: https://www.commercialprogression.com/post/5-step-guide-easier-file-and-database-syncing-drush

So far, the aliases for the live site and the local site seem to work. But the one for the test site doesn't (do you know what it shoud be?) and, in the process I've messed that site up again. Can drush cause this?? Here is the error message that I get when I try to go to the site in my browser:

nitialization Error

Array (

[callback] => Array

(

[0] => CRM_Core_Error [1] => simpleHandler

)

[code] => -24 [message] => DB Error: connect failed [mode] => 16 [debug_info] => [nativecode=Access denied for user 'liz_commons'@'localhost' (using password: YES)] [type] => DB_Error [user_info] => [nativecode=Access denied for user 'liz_commons'@'localhost' (using password: YES)] [to_string] => [db_error: message="DB Error: connect failed" code=-24 mode=callback callback=CRM_Core_Error::simpleHandler prefix="" info=" [nativecode=Access denied for user 'liz_commons'@'localhost' (using password: YES)]"]

)

I removed the liz_commons db user but that didn't help. And, I had a backup and migrate backup and imported it with phpmyadmin it but still have the problem.

Thanks again, Liz

comment:3 Changed 4 years ago by https://id.mayfirst.org/lizmestres

Hi Ross, Thanks, I was able to get here from a different browser. The question is can you let me know what's possible on the issues raised in this ticket? Best, Liz

Please login to add comments to this ticket.

Note: See TracTickets for help on using tickets.