Opened 4 years ago

Closed 4 years ago

#10067 closed Bug/Something is broken (fixed)

Log-ins always delayed

Reported by: https://id.mayfirst.org/cpicher Owned by: https://id.mayfirst.org/srevilak
Priority: High Component: Tech
Keywords: roundcube, julia.mayfirst.org Cc: cpicher@…
Sensitive: no

Description

Ever since I got account, I've never been able to log in without connection delays. I've lived with it so far, but now the problem has gotten worse. Here is what always happens: 1- I write my user name and password. 2- I log in. 3- Inbox screen appears with message that says "connecting" 4- But connection does not occur, and after about 10 seconds, announcement saying "internal server error" pops up. 5- So then I've learned that if I click on INBOX, step 3 happens again, and this time I get to see my messages. 6- HOWEVER, since this past summer, the delay has increased: the "internal server error" message keeps on popping up when I click on INBOX-- from 2 to 4 times-- on the screen before I can get messages.

I would like to be able to be able to log in and get messages right away.

Thank you.

Change History (9)

comment:1 Changed 4 years ago by https://id.mayfirst.org/dskallman

  • Keywords julia.mayfirst.org added
  • Owner set to https://id.mayfirst.org/ross
  • Status changed from new to assigned

You main account is on julia, which has experienced some issues lately. I am bringing Ross in to provide more detail.

Dana

comment:2 Changed 4 years ago by https://id.mayfirst.org/ross

  • Owner changed from https://id.mayfirst.org/ross to https://id.mayfirst.org/srevilak

I'm not sure if this is a julia issue. This sounds like roundcube or horde. Can you tell us what url you are using to access your email. I'm also going to ask Steve to look into this.

comment:3 Changed 4 years ago by https://id.mayfirst.org/srevilak

Ross - thanks for passing this along.

cpicher - sorry for the inconvenience with your INBOX. We'll try to get this sorted out.

comment:4 Changed 4 years ago by https://id.mayfirst.org/srevilak

Some tech notes:

most recent /var/log/roundcube/error that mentions cpicher

[04-Sep-2014 00:00:29 -0400]: IMAP Error: Login failed for cpicher from w.x.y.z. LOGIN: failed: Could not determine server in /srv/roundcube/program/lib/Roundcube/rcube_imap.php on line 184 (GET /?_task=mail&_id=***&_action=compose)

on paulo, I see successful logins (coming from stallman) at

  • Oct 1 15:42:52
  • Oct 1 15:47:53
  • Oct 1 16:53:39

on gil, I see successful logins (coming from stallman) at

  • Oct 1 15:56:43
  • Oct 1 15:51:50

There are several HTTP 500's in roundcube's access log, from around 16:00 on Oct 1st. There are also FastCGI timeouts around this period.

comment:5 Changed 4 years ago by https://id.mayfirst.org/srevilak

Hello cpicher,

I've done some investigation, and wanted to get back to you regarding the webmail timeouts. I understand your frustration -- it's a pain to see an Internal Server Error when you're trying to check your Inbox.

The first thing I'd like to do is to confirm which webmail system you were using: roundcube.mayfirst.org ("roundcube") or webmail.mayfirst.org ("horde"). I suspect the former, but it would be helpful to know for sure.

I see that your Inbox has ~ 2600 messages. That's not a huge number, but it's also not a tiny number. Our IMAP server has to scan through those messages in order to build your inbox listing, so the more messages you have, the longer it takes to scan through them. If it's feasible to move some of those messages to another folder, that would likely help.

You may have better results with a more traditional mail client, like Thunderbird, particularly if you enable offline caching. That should speed things up a lot. We have an article on Thunderbird setup at https://support.mayfirst.org/wiki/faq/email/setup-thunderbird; there are setup instructions for other mail programs here: https://support.mayfirst.org/wiki/faq/email.

As much as I'd like to say "found the problem and it's fixed now", I'm not at the point where I can do that.

Please let me know which webmail URL you were using when the Internal Server Errors occurred; and let me know if you'd be willing to try a traditional mail program. Thanks for your patience.

Steve

comment:6 Changed 4 years ago by https://id.mayfirst.org/cpicher

Dear Steve,

Thank you for your prompt reply and comments. Sorry for my delayed response.

My URL is Roundcube.

Thank you for reminding me of my 2600 plus messages in my mailbox! I will take care of it as quickly as possible.

I don't wish to change to another mail client yet. I'll begin by cleaning out the mailbox, and then I'll see.

By the way, I only got one "internal server error" message when I logged in today, so that's already an improvement.

Thanks again for your help.

Claire

comment:7 Changed 4 years ago by https://id.mayfirst.org/srevilak

Claire, thanks for getting back to me. Let me know if the inbox cleanup makes any improvement.

comment:8 Changed 4 years ago by https://id.mayfirst.org/srevilak

  • Resolution set to fixed
  • Status changed from assigned to feedback

Hi Claire. We haven't been in touch for a while, and I wanted to check back and see how things were going. Are you still experiencing slow logins?

comment:9 Changed 4 years ago by automatic

  • Status changed from feedback to closed

No news is good news (we hope)! Given the lack of feedback, we think this ticket can be closed.

Please login to add comments to this ticket.

Note: See TracTickets for help on using tickets.