Opened 5 years ago

Last modified 4 years ago

#10008 assigned Bug/Something is broken

again email and website emails do not match

Reported by: https://id.mayfirst.org/portside-submission Owned by:
Priority: Urgent Component: Tech
Keywords: Cc: ross@…, jamie@…, bxcohen@…, jschaffner@…, jschaffner14@…
Sensitive: no

Description

need to fix web URL to match what went out in email (https went out in email - web is http)

email - https://portside.org/2014-09-12/canadian-mining-company-threatens-el-salvadors-sovereignty

web - http://portside.org/2014-09-13/canadian-mining-company-threatens-el-salvadors-sovereignty

Think that this problem was caused by creating a post, but not publishing on Thursday; then going and editing and publishing on Saturday.

How do we automate that this doesn't happen every week?

Jay

Change History (11)

comment:1 Changed 5 years ago by https://id.mayfirst.org/ross

Hi Jay,

I think in this particular case, you need to uncheck the automatic url alias button for content that has already been created. My guess is that when the content was edited a new automatic url alias was created using a different date.

I've added the redirect so the email should lead to the correct story,

~/ross

comment:2 Changed 5 years ago by https://id.mayfirst.org/portside-submission

Ross,

Many thanks. Have advised the two moderators who create in advance about this. We have moderators conference call on Oct. 5 - will use that time to go over whatever needs to be updated, covered, etc. We can talk about this when we talk.

Jay

comment:3 Changed 5 years ago by https://id.mayfirst.org/ross

  • Resolution set to fixed
  • Status changed from new to closed

Sounds good. I expect to have a more long term solution by October.

comment:5 Changed 5 years ago by https://id.mayfirst.org/portside-submission

additional information - all were created in advance - day before

comment:6 Changed 5 years ago by https://id.mayfirst.org/ross

Hi Jay,

I'm not sure what the problem is you're seeing with having https vs. http. Any https link is directed to the http protocol anyway. So these links are all correctly using https.

All of the links you posted work fine using https. That is to say, they are already being redirected.

Can you tell me what you see the problem to be?

~/ross

comment:7 Changed 5 years ago by https://id.mayfirst.org/portside-submission

Sorry for long delay in responding. Was at huge climate change demonstration.

I gave URLs from website. URLs in emails did not work previously. They now do. They are http.

Think the problem is that when posts are set up in advance of day of posting, then when they are posted on a different day, even with no changes - no edits - just the act of re-opening and then saving - this is what creates the different URL. Unchecking the box might help.

Moderator told me that last week, there were no edits - no re-opening - they were just set to publish one day after creation. This would be a totally different problem than making edits and un-checking URL creation box.

Jay

comment:8 Changed 4 years ago by https://id.mayfirst.org/portside-submission

Fix on URL re-direct did not work.

Emails contain URL that is https and with date of original set-up (Sept. 25 for four of the posts; Sept. 26 for last one) Web site has URL with date of publication (Sept. 27) and is http

Below are five Saturday posts. Only have email URL for two of them - did not yet receive the others.

Congressional Democrats Demand End to Child Labor in Tobacco Fields

web URL - http://portside.org/2014-09-27/congressional-democrats-demand-end-child-labor-tobacco-fields

=====

Israel Outsources West Bank Security to "Uncontrolled Militias"

web URL - http://portside.org/2014-09-27/israel-outsources-west-bank-security-uncontrolled-militias

=====

Brazilian President Dilma Rousseff Leads on Eve of Crucial Vote

web URL - http://portside.org/2014-09-27/brazilian-president-dilma-rousseff-leads-eve-crucial-vote

=====

Major Clothing Brands Agree to More Pay for Cambodian Garment Workers

web URL - http://portside.org/2014-09-27/major-clothing-brands-agree-more-pay-cambodian-garment-workers

email URL - https://portside.org/2014-09-25/major-clothing-brands-agree-more-pay-cambodian-garment-workers

=====

"Pro-Sustainability" Companies Funding Climate Change Denial

web URL - http://portside.org/2014-09-27/pro-sustainability-companies-funding-climate-change-denial

email URL - https://portside.org/2014-09-25/pro-sustainability-companies-funding-climate-change-denial

comment:9 Changed 4 years ago by https://id.mayfirst.org/portside-submission

  • Resolution fixed deleted
  • Status changed from closed to assigned

Ross,

Maybe fix would work - these messages were crated before you made change.

Jay

comment:10 Changed 4 years ago by https://id.mayfirst.org/ross

Hi Jay,

I'm not sure what the problem is you see. With this new infrastructure in place, you should not need to touch the automatic url setting. In fact it's now better if everyone leaves the generate automatic url checkbox clicked.

The change I made automatically redirects changed urls, which means what you might see as the wrong link in emails will still take people to the correct link. If you click on any of the email links you mentioned, they take the user to the correct page. Which is the appropriate solution for urls that change.

That is to say, the fix did in fact work.

~/ross

comment:11 Changed 4 years ago by https://id.mayfirst.org/portside-submission

Hi Ross,

Just re-tried it. It works. Congrats and many thanks. First time I tried, when I did the ticket, on the two email URLs that I had, it did not work.

Will we have anything to show people for our Moderators Conference Call on Sunday, Oct. 5? (this change is something that will make people smile)

Thanks.

Jay

Please login to add comments to this ticket.

Note: See TracTickets for help on using tickets.